请老师写一个当公式中的绿色变成玫瑰红色时的选股公式,谢谢!

admin 92 2024-02-08 20:23:02

DRAWGBK(C>1,RGB(0,0,0),RGB(1,1,1),1,0,0);

DIFF:=EMA(收盘价,8)-EMA(收盘价,13);

DEA:=EMA(DIFF,5);

STICKLINE(DIFF>=DEA,5,10,2,1),彩色;

粘线(差异

RSV1:=(收盘-LLV(低,8))/(HHV(高,8)-LLV(低,8))*100;

K:=SMA(RSV1,3,1);

D:=SMA(K,3,1);

粘线(K>=D,10,15,2,1),彩色;

粘线(K

LC:=REF(收盘,1);

RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;

RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;

粘线(RSI1>=RSI2,15,20,2,1),彩色;

粘线(RSI1

RSV:=-(HHV(高,13)-收盘)/(HHV(高,13)-LLV(低,13))*100;

LWR1:=SMA(RSV,3,1);

LWR2:=SMA(LWR1,3,1);

粘线(LWR1>=LWR2,20,25,2,1),彩色;

粘线(LWR1

BBI:=(MA(收盘,3)+MA(收盘,6)+MA(收盘,12)+MA(收盘,24))/4;

STICKLINE(收盘价>=BBI,25,30,2,1),彩色;

STICKLINE(CLOSEMTM:=CLOSE-REF(CLOSE,1);

MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);

MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);

STICKLINE(MMS>=MMM,30,35,2,1),彩色;

粘线(彩信

MAV:=(C*2+H+L)/4;

SK:=EMA(MAV,13)-EMA(MAV,34);

SD:=EMA(SK,5);

空方主力:=(-2*(SK-SD))*3.8,COLORGREEN;

多方主力:=(2*(SK-SD))*3.8,COLORRED;

STICKLINE(长边主力>=短边主力,37,42,2,0),COLORRED;

STICKLINE(主要MA11,43,48,2,0),COLORGREEN;

STICKLINE(MA22=空头主力) AND(MA22=散户),56,61,3,0),COLORYELLOW;

STICKLINE((主力MA11) AND (主力=主力空头) AND (MA22=散户) AND (DIFF>=DEA) AND (K>=D) AND (RSI1>=RSI2) AND (LWR1>=LWR2 ) AND (CLOSE>=BBI) AND (MMS>=MMM),63,68,3,0), 洋红色;

X_1:=MA(收盘价,10);

X_2:=MA(收盘价,55);

X_3:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;

X_4:=过滤器(X_3,10);

X_5:=BARSLAST(X_4);

X_6:=REF(高,X_5+2);

X_7:=REF(高,X_5+1);

X_8:=REF(高,X_5);

X_9:=MAX(X_6,X_7);

X_10:=MAX(X_9,X_8);

X_11:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;

X_12:=X_5

X_13:=(打开-X_10)/X_10*100

X_14:=(CLOSE-LLV(LOW,X_5))/LLV(LOW,X_5)*100X_15:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100

X_16:=成交量/MA(成交量,5)

X_17:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100

X_18:=X_11 与 X_12 与 X_13 与 X_14 与 X_15 与 X_16 与 X_17;

X_19:=过滤器(X_18,15);

X_20:=(关闭-X_2)/X_2

X_21:=(关闭-X_1)/X_1

X_22:=(X_20=1 且 X_21=1)*0.2;

X_23:=(X_22=0 AND REF(X_22,1)=0.2 AND REF(COUNT(X_22=0.2,10)=10,1)=1)*(-0.1);

X_24:=X_23=(-0.1);

X_25:=X_19 或 X_24;

X_27:=VOL/REF(VOL,1)>1.2 且收盘>开盘或 (LOW>REF(HIGH,1) 且开盘>收盘且 VOL/REF(VOL,1)>1.2);

X_28:=IF(CODELIKE(3) OR (CODELIKE(4) AND DATE>=1200824),CLOSE>=ZTPRICE(REF(CLOSE,1),0.2) AND CLOSE=HIGH,CLOSE>=ZTPRICE(REF(CLOSE, 1),0.1) 且收盘价=最高);

X_29:=X_25 AND X_27 AND RSI1>=RSI2) AND (LWR1>=LWR2) AND (CLOSE>=BBI) AND (MMS>=MMM) AND DIFF>=0;

中:=MA(C,15)*1.005;

VART1:=POW((C-MID),2);

VAR2:=MA(VAR1,15);

VART3:=SQRT(VART2);

上:=中+2*VART3;

下:=MID-2*VART3;

月亮线:=REF(UPPER,1),COLOR00FFFF;

{DRAWICON(CLOSE>月亮线,LOW,9);

DRAWICON(REF(C,1)>兰岳线 AND CLOSE0) AND (REF(AA,1)=空方主力) AND (MA22=散户) AND (DIFF>=DEA) AND (K>=D) AND (RSI1>=RSI2) AND (LWR1>=LWR2) AND (CLOSE>=BBI) AND (MMS>=MMM) AND (DIFF>=0);

DRAWICON(X_29 或 X_30,79,25);

此帖寻求各位老师的解答

846.middle

上一篇:三种有效止损方法
下一篇:《指标书写互助及问答区》新规则,有重要改革(新增勋章),发帖时必读!
相关文章

 发表评论

暂时没有评论,来抢沙发吧~

返回顶部小火箭